jump to article
...intermittent thoughts

Nun also auch die Deutsche Bank

Ich muss ja schon sagen - es steckt doch einiges an Mühe hinter diesem Fake! sogar eine Domain wurde beantragt. Ok, als .com TLD, und auch noch mit einem minimalen Rechtschreibfehler, aber irgendwie hat das schon Klasse. Naja, die Rechtschreibfehler die im Text sind, fallen natürlich auch auf, abr die könnten auch bei der echten Deutschen Bank entstanden sein - ich erinnere mich dunkel an eine Werbepostille von einer ehmealigen Tochter - die war so konfus, das nicht einmal Sätze beendet worden waren (abgesehen von ziemlich offenscihtlichen Rechenfehlern).

Wie dem auch sei - ich hoffe es gibt bei der DB leute, die heute arbeiten und möglichst schnell gegen diesen Server vorgehen.

Image:Nun also auch die Deutsche Bank

IE closer to the standard than Firefox?

Today I learned something new about Javascript and IE. Never, never use special signs in your Javascript code!
We had occasional erros on a longer (some hundret lines) JavaScript library used in a website which was initally my work. Sometimes we got erros like 'ob' is not defined. Well ob is a variable in that script used as temporary object container in several functions. After a lot of searching and loads of stupid debuging code inserts I found it: the line just before one setting of ob was a line with an umlaut so the code looked like this:


... some piece of code
// this is a comment with an 'ü' in it
var ob=otherobject;
... some piece of code


well, what IE does here, is really funny. the line with the special sign in it gets missformatted sometimes and the line ending is not recognized. So the code becomes for the Internet Explorer like this:


... some piece of code
// this is a comment with an *&!(!S in it var ob=otherobject;
... some piece of code


If you execute the code, ob is never set to otherobject - though the code causes an error when trying to acces the variable ob some lines later. if you leave the ü out of the comment - nothing gets missformatted and the code is working as expected.

Well, Firefox can handle such javascript code - for myself I learned the hard way to not use umlauts or special signs in my javascript code comments anymore...

Heul-SUSE Teil 2

So, jetzt hab ich drei Stunden darauf gewartet, meine SUSE Personal Edition zu installieren. Mittlerweile ist der Boot-Bildschirm tatsächlich einem Installationsbildschirm gewichen und vor ca. 1,5h habe ich tatsächlich einer Software-Lizenz zugestimmt. Seit diesem Zeitpunkt hat die Installationsroutine nun doch schon zum zweiten mal meine Fetsplattentreiber in den Kernel geladen und die USB-Geräte neu eingebunden. Zudem wurde inzwischen erkann, dass ich einen Klamath, also Pentium II im Einsatz habe und dass der RAM 768MB beträgt. Wirklich toll! Nun bin ich endgültig müde und frustriert. Ich hab mir zwar gedacht, dass Linux ein paar zu lösende Probleme mit sich bringen wird, aber nie daran, dass es einfach an der Zeit hängen könnte...
Wärend ich das schreibe hat er meine USB Maus als IntelliMouse (USB) erkannt. Dummerweise hängt die Intellimaus haber an Com1 und am USB hängt eine Maus, die garantiert KEINE IntelliMouse ist.
Ich denke, ich kann es mir nicht leisten SUSE zu installieren - es ist mir einfach zu langsam - knapp hochgerechnet steht ja die eigentliche Arbeit noch bevor, was dann heisst, dass ich nachdem ich jetzt ma locker 5,5 h an der Installation bin wahrscheinlich noch 48 h installieren werde...

Heul-SUSE

nachdem ich schon oft mit dem Gedanken gespielt habe, mal wieder ein wenig mit Linux "rumzumachen", habe ich mir heute meinen alten Dual PII aus dem Keller geholt und geplättet: die alten Daten gesichert, ein wenig mehr RAM rein und eine neue Tastatur gekauft. Danach die SUSE 9.3 Personal aus der c't rein und ab dafür. Die Sache fing tatsächlich recht viel versprechend an: die DVD bootet sofort und man bekommt auch einen wirklich netten Begüßungsbildschirm in einen schön gebrandeten Grün. Das Novell Logo sehe ich neben dem SUSE Logo auch schon. Prima. Nach Auswahl von "Installation" gings dann auch nach zwei drei Minuten los - ok, der Rechner ist ein bisschen älter.
irgendwann wechselte dann der schwarze Bildschirm wieder auf einen grünen. Momentan sehe ich seit 15 Minuten das SUSE Logo, das Novell Logo und als letztes die Zeile:
>>> SUSE Linux installation program v1.8.6 (c) 1996-2005 SUSE Linux Products GmbH <<<

Ich bin ziemlich deprimiert! Meine USB-Tastatur ist momentan deaktiviert und ich bekomme keine Rekation mehr vom System. Wie soll das nur weiter gehen...